Samsung Galaxy S5 Android Lollipop "Your device is not compatible with this version" Google Play Store

It can happen to your Samsung Galaxy S5 after the firmware update to Android Lollipop, that you find the following message instead of the download button in the Google Play Store:

"Your device is not compatible with this version"

What does the message mean on your Samsung Galaxy S5?

If you can see the above message in your Google Play Store on the Samsung Galaxy S5, then this has to do with the new Android lollipop version. The app, you want to download is not designed for the new Runtime "ART", which is implemented with Android Lollipop. Therefore  it is not possible to download the app. Remedy, unfortunately, can only be done by the programmer of the app.



This tip helped? Stay up-to-date and follow us on:

Nothing found?

Try our:

Search

... Or leave us a comment:

Comments (0)

There are no comments posted here yet

Leave your comments

  1. Posting comment as a guest.
0 Characters
Attachments (0 / 3)
Share Your Location